Not signed in (Sign In)
The Intervals Forum is Closed.
This forum has been replaced with a help section located at help.myintervals.com.
We recommend checking the help section, as the forums are no longer being updated. If you have any questions, please don't hesitate to contact our support team.

Tips & Tricks

Intervals running slow in Firefox as a result of Web Developer and Firebug addons

Bottom of Page

1 to 2 of 2

  1.  
  1.  

    We've been receiving a small number of emails about Intervals running slow. And while we are working on some optimizations that will make the app significantly faster, there are two things that Firefox users can do to make sure the application is not being impeded by addons.

    We figured this one out the hard way as well. Being web application developers by nature, we all have the Web Developer and Firebug toolbars installed and enabled to help debug as we develop. Turns out they both present problems that will slow down web sites. And since many of our customers are web developers, there is a good chance they have these addons enabled in a similar manner.

    First, let's start with the Web Devleoper addon. If you have it installed, go to Tools -> Web Developer -> Disable and make sure that "Disable Cache" is unchecked. This one step alone will significantly increase the speed in Intervals, as it will allow your browser to cache static content like stylesheets, javascripts, and images.

    Second, disable Firebug. This will result in having to restart Firefox. The problem we found with Firebug is that it was meddling with the cache. Cached content that should have been returning 304 headers from the server were alternately returning 200, 304, 200, 304. It turns out that Firebug was not always transimitting the "If-modified-since" header, which was resulting in the cache being disabled for certain files.

    So try these two updates and let us know if it makes a difference. We're hoping it will. If this doesn't apply to you and the site still feels slow, stay tuned for several performance optimizations to be launched next week and the week after.

    Thanks for all the feedback everyone.

    Regards,
    John

    • jprado
    • Jul 17th 2009 edited @ 07/17/2009 11:42 am
     

    Firebug users:

    Currently there is a Firefox 3.5 bug and Firebug 1.4.0 bug that affects ajax tables and prevents them from loading completely.

    The resulting console error is:

    onreadystatechange FAILS
    Error: Permission denied for <https://pelago.projectaccount.com> to create wrapper for object of class UnnamedClass
    Error: Permission denied for <https://pelago.projectaccount.com> to create wrapper for object of class UnnamedClass
    readystatechange

    This isn't verified but it helps if 'Show XMLHttpRequests' is set to disabled. The fix might help until Firebug releases a bugfix.

    Some other workarounds are listed here.

Comments are closed.
For more Intervals help documentation, please visit help.myintervals.com